Varnish Cache Test

Varnish PHP Cache Test can be done with a simple PHP Script. For testing, we will use a random generator script that will generate random numbers between 1-99 on each refresh/reload from the browser. Test script: varnish-test.php * You would need to place the script in your domain folder and then open it from the…

Copy Local Backup to Google Drive

Instructions to Copy Local Backup to Google Drive as an additional backup copy. Download GDrive binary # For x64 wget -O gdrive https://drive.google.com/uc?id=1Ej8VgsW5RgK66Btb9p74tSdHMH3p4UNb&export=download # More versions: https://github.com/gdrive-org/gdrive Move and Permissions mv gdrive /usr/sbin/gdrive chmod 755 /usr/sbin/gdrive Authentication process To generate the authentication URL just run: gdrive # The client must paste the link in his…

Detection and Remediation for Cyclops Blink State-Sponsored Botnet

Working closely with the FBI, CISA, DOJ, and UK NCSC1, WatchGuard has investigated and developed a remediation for Cyclops Blink, a sophisticated state-sponsored botnet, that may have affected a limited number (estimated at ~1%) of WatchGuard firewall appliances. WatchGuard customers and partners can eliminate the potential threat posed by malicious activity from the botnet by…

ClamAV Issues

ERROR: Can’t download daily.cvd from database.clamav.net WARNING: Your ClamAV installation is OUTDATED! WARNING: Local version: 0.101.2 Recommended version: 0.103.5 DON’T PANIC! Read https://www.clamav.net/documents/upgrading-clamav main.cld is up to date (version: 62, sigs: 6647427, f-level: 90, builder: sigmgr) WARNING: getpatch: Can’t download daily-26440.cdiff from database.clamav.net WARNING: getpatch: Can’t download daily-26440.cdiff from database.clamav.net ERROR: getpatch: Can’t download daily-26440.cdiff…

MariaDB Upgrade to the new version

Before starting an upgrade please confirm that you have the backup of MySQL databases and users. Default backup is in the folder /backup/mysql Also, make sure all your scripts/sites are compatible with the new version as there is no return back to an old version. Check which version of MariaDB is installed on your server…

PHP Defender – Snuffleupagus

PHP Defender – Snuffleupagus This is a PHP security module that has a custom configuration for each PHP version Supported PHP versions are PHP 7 and PHP 8. Configuration locations MAIN PHP-CGI /usr/local/php/php.d/snuffleupagus.ini Configuration locations PHP-FPM /opt/alt/php-fpm70/usr/php/php.d/snuffleupagus.ini /opt/alt/php-fpm71/usr/php/php.d/snuffleupagus.ini /opt/alt/php-fpm72/usr/php/php.d/snuffleupagus.ini /opt/alt/php-fpm73/usr/php/php.d/snuffleupagus.ini /opt/alt/php-fpm74/usr/php/php.d/snuffleupagus.ini /opt/alt/php-fpm80/usr/php/php.d/snuffleupagus.ini /opt/alt/php-fpm81/usr/php/php.d/snuffleupagus.ini Configuration locations PHP-CGI /opt/alt/php70/usr/php/php.d/snuffleupagus.ini /opt/alt/php72/usr/php/php.d/snuffleupagus.ini /opt/alt/php74/usr/php/php.d/snuffleupagus.ini /opt/alt/php71/usr/php/php.d/snuffleupagus.ini /opt/alt/php73/usr/php/php.d/snuffleupagus.ini /opt/alt/php80/usr/php/php.d/snuffleupagus.ini /opt/alt/php81/usr/php/php.d/snuffleupagus.ini Configuration files…